Downloading Couchdbkit

This is a manual for installing Couchdbkit and its dependencies.

1. Installing CouchDB

Couchdbkit requires couchdb 0.11 or later to use it.

To install Couchdb follow the documentation on CouchDB wiki .

2. Installing Couchdbkit

Couchdbkit requires python2.x >= 2.6.0 to work. python 3.x will be supported soon.

To install couchdbkit using pip you must make sure you have a
recent version of distribute installed:

    $ curl -O http://python-distribute.org/distribute_setup.py
    $ sudo python distribute_setup.py
    $ easy_install pip

To install or upgrade to the latest released version of couchdbkit:

    $ pip install couchdbkit